ZED_SDK_Update2

New ZED SDK 0.9 Adds Jetson TK1 and ROS Support

ZED SDK 0.9 for Windows and Linux is now available for download on our Developer page. The release is a major update to the ZED SDK, bringing with it support for NVIDIA Jetson TK1, ROS and CUDA 7.

0.9 also includes new tools, samples and documentation that simplify the development of applications with the ZED stereo camera, along with various performance improvements as well as a few fixes.

New Tools and Samples

As part of 0.9, we have introduced a new Depth Viewer tool and new samples including ROS, CUDA, Recording and Playback, along with a complete refactoring of existing samples to make them more accessible and easy to use.

Jetson TK1 Support

nvidiajetsontk1_topThe ZED SDK for Jetson TK1 has been released! While the SDK in still in Alpha version, most of the functionalities offered in the ZED SDK for Linux are available. We are still working closely with NVIDIA to unlock higher resolution and frame rates, which is a challenge considering that the ZED can output on a single USB 3.0 interface 3840*1080 video at 30 FPS!

ROS Compatibility

zedCameraROS2We heard you! We had many requests for ROS support, so we created a wrapper that is now available in the Linux SDK. You will be able to use your ZED either as a stereo camera sending left and right images or as a depth sensor sending both color images and depth.

The wrapper has been designed for the current stable ROS version (Indigo) as a catkin package and should also work with other version of ROS with minimal or no modifications at all.

Read more about the new ROS wrapper here: Using ZED camera with ROS

CUDA 7

LUOWehvo

The new ZED SDK 0.9 for Windows now supports CUDA 7.0. Since CUDA 7.0 no longer supports building 32 bits applications, the support of Win32 is now only available with the CUDA 6.5 version (available here) and is now deprecated.

In future SDK releases, the ZED SDK for Linux will be using CUDA 6.5 in order to maintain interoperability with the Jetson TK1. On Windows, the support of CUDA 6.5 and 32 bits will be dropped.

The Road Ahead

We’re very excited about this update and want to thank you all for your feedback and participation in helping us improve the ZED. But the work doesn’t stop here. We’ve got some really exciting stuff in the works to continue adding to and expanding the use of the ZED and stereo vision around the world.

Thanks so much for all of your support and feedback, and stay tuned!

– The ZED team

 

  • Pablo Molina

    what are the framerates and resolutions we should expect with a Jetson running the ZED code?

    • With the current alpha version of ZED SDK on Jetson, you can expect up to 15 FPS with compatible resolution. Will be improving this in future SDK updates!

  • dwyer2bp

    Is CUDA 7.0 required to run the SDK on the NVIDIA Jetson for the 0.9 release?

    • CUDA 7.0 is only required for ZED SDK on Windows. For Jetson TK1 and Linux, you need to use CUDA 6.5.

  • dwyer2bp

    The 0.9 Linux release does not work for the Jetson TK1, unlike the information provided in this post. Any reason why? Is this release not supposed to support the Jetson TK1?